---
id: CVE-2025-38430
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  nfsd: nfsd4_spo_must_allow() must check this is a v4 compound request

  If the request being processed is not a v4 compound request, then
  examining the cstate can have u…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  nfsd: nfsd4_spo_must_allow() must check this is a v4 compound request

  If the request being processed is not a v4 compound request, then
  examining the cstate can have u…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: linux
product: linux_kernel
affected:
  - linux_kernel < 5.4.295
  - 'linux_kernel >= 5.5, < 5.10.239'
  - 'linux_kernel >= 5.11, < 5.15.186'
  - 'linux_kernel >= 5.16, < 6.1.142'
  - 'linux_kernel >= 6.2, < 6.6.95'
  - 'linux_kernel >= 6.7, < 6.12.35'
  - 'linux_kernel >= 6.13, < 6.15.4'
  - debian_linux = 11.0
patched:
  - linux_kernel 6.15.4
published: '2025-07-25'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T22:18:40.823'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-38430'
references:
  - url: 'https://git.kernel.org/stable/c/1244f0b2c3cecd3f349a877006e67c9492b41807'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/2c54bd5a380ebf646fb9efbc4ae782ff3a83a5af'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/425efc6b3292a3c79bfee4a1661cf043dcd9cf2f'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/64a723b0281ecaa59d31aad73ef8e408a84cb603'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/7a75a956692aa64211a9e95781af1ec461642de4'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/b1d0323a09a29f81572c7391e0d80d78724729c9'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/bf78a2706ce975981eb5167f2d3b609eb5d24c19'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/e7e943ddd1c6731812357a28e7954ade3a7d8517'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-082556.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00596
epssPercentile: 0.48297
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-15T21:50:20.466355Z'
ingestedAt: '2026-10-15T05:52:46.087Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

nfsd: nfsd4_spo_must_allow() must check this is a v4 compound request

If the request being processed is not a v4 compound request, then
examining the cstate can have undefined results.

This patch adds a check that the rpc procedure being executed
(rq_procinfo) is the NFSPROC4_COMPOUND procedure.

## Affected

- `linux_kernel < 5.4.295`
- `linux_kernel >= 5.5, < 5.10.239`
- `linux_kernel >= 5.11, < 5.15.186`
- `linux_kernel >= 5.16, < 6.1.142`
- `linux_kernel >= 6.2, < 6.6.95`
- `linux_kernel >= 6.7, < 6.12.35`
- `linux_kernel >= 6.13, < 6.15.4`
- `debian_linux = 11.0`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.15.4`
