---
id: CVE-2025-38466
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  perf: Revert to requiring CAP_SYS_ADMIN for uprobes

  Jann reports that uprobes can be used destructively when used in the
  middle of an instruction
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  perf: Revert to requiring CAP_SYS_ADMIN for uprobes

  Jann reports that uprobes can be used destructively when used in the
  middle of an instruction. The kernel only veri…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-266
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 5.8, < 5.10.240'
  - 'linux_kernel >= 5.11, < 5.15.189'
  - 'linux_kernel >= 5.16, < 6.1.146'
  - 'linux_kernel >= 6.2, < 6.6.99'
  - 'linux_kernel >= 6.7, < 6.12.39'
  - 'linux_kernel >= 6.13, < 6.15.7'
  - linux_kernel = 6.16
  - debian_linux = 11.0
patched:
  - linux_kernel 6.15.7
published: '2025-07-25'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T22:18:42.050'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-38466'
references:
  - url: 'https://git.kernel.org/stable/c/183bdb89af1b5193b1d1d9316986053b15ca6fa4'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/8e8bf7bc6aa6f583336c2fda280b6cea0aed5612'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/a0a8009083e569b5526c64f7d3f2a62baca95164'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/ba677dbe77af5ffe6204e0f3f547f3ba059c6302'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/c0aec35f861fa746ca45aa816161c74352e6ada8'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d5074256b642cdeb46a70ce2f15193e766edca68'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d7ef1afd5b3f43f4924326164cee5397b66abd9c'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://lists.debian.org/debian-lts-announce/2025/10/msg00007.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2025/10/msg00008.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-082556.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-38466.json
  - url: 'https://access.redhat.com/security/cve/CVE-2025-38466'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2383482'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2025-38466'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-38466'
  - url: >-
      https://lore.kernel.org/linux-cve-announce/2025072508-CVE-2025-38466-11e8@gregkh/T
tags:
  - nvd
  - csaf
  - vex
  - red-hat
  - cve.org
  - score-dispute
epss: 0.00233
epssPercentile: 0.14166
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-15T21:50:41.107124Z'
scores:
  nvd: 7.8
  vendor: 4.4
  cna: 7.8
ingestedAt: '2026-10-15T05:52:46.087Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

perf: Revert to requiring CAP_SYS_ADMIN for uprobes

Jann reports that uprobes can be used destructively when used in the
middle of an instruction. The kernel only verifies there is a valid
instruction at the requested offset, but due to variable instruction
length cannot determine if this is an instruction as seen by the
intended execution stream.

Additionally, Mark Rutland notes that on architectures that mix data
in the text segment (like arm64), a similar things can be done if the
data word is 'mistaken' for an instruction.

As such, require CAP_SYS_ADMIN for uprobes.

## Affected

- `linux_kernel >= 5.8, < 5.10.240`
- `linux_kernel >= 5.11, < 5.15.189`
- `linux_kernel >= 5.16, < 6.1.146`
- `linux_kernel >= 6.2, < 6.6.99`
- `linux_kernel >= 6.7, < 6.12.39`
- `linux_kernel >= 6.13, < 6.15.7`
- `linux_kernel = 6.16`
- `debian_linux = 11.0`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.15.7`

## Vendor advisories

- **Red Hat VEX** · Moderate · affected: Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · no fix planned: Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 · updated 2026-10-16 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-38466.json)
