---
id: CVE-2025-49655
aliases:
  - GHSA-cvhh-q5g5-qprp
  - PYSEC-2026-368
title: Keras framework vulnerable to deserialization of untrusted data
summary: Keras framework vulnerable to deserialization of untrusted data
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: keras
product: keras
ecosystem: pip
affected:
  - 'keras >= 3.11.0, < 3.11.3'
patched:
  - keras 3.11.3
published: '2025-10-17'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T17:30:37.908610942Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-cvhh-q5g5-qprp'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-49655'
  - url: 'https://github.com/keras-team/keras/pull/21575'
  - url: 'https://github.com/keras-team/keras'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/keras/PYSEC-2026-368.yaml
  - url: 'https://hiddenlayer.com/sai_security_advisor/2025-10-keras'
  - url: 'https://pypi.org/project/keras'
  - url: 'https://github.com/advisories/GHSA-cvhh-q5g5-qprp'
tags:
  - osv
  - pip
  - ghsa
epss: 0.0075
epssPercentile: 0.54738
cwe:
  - CWE-502
ingestedAt: '2026-10-27T17:33:23.770Z'
---

## Overview

Deserialization of untrusted data can occur in versions of the Keras framework running versions 3.11.0 up to but not including 3.11.3, enabling a maliciously uploaded Keras file containing a TorchModuleWrapper class to run arbitrary code on an end user’s system when loaded despite safe mode being enabled. The vulnerability can be triggered through both local and remote files.

## Affected packages

- `keras >= 3.11.0, < 3.11.3`

## Remediation

Upgrade to a patched release:

- `keras 3.11.3`
