---
id: CVE-2025-54550
title: "The example example_xcom\_that was included in airflow documentation implemented unsafe pattern of reading value\nfrom xcom in the way that could be exploited to allow UI user who had access to modify XComs to perform arbitrary\nexecution o…"
summary: "The example example_xcom\_that was included in airflow documentation implemented unsafe pattern of reading value\nfrom xcom in the way that could be exploited to allow UI user who had access to modify XComs to perform arbitrary\nexecution o…"
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-94
vendor: apache
product: airflow
affected:
  - airflow < 3.2.0
patched:
  - airflow 3.2.0
published: '2026-04-15'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T09:10:00.160'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-54550'
references:
  - url: 'https://github.com/apache/airflow/pull/63200'
    label: security@apache.org
  - url: 'https://lists.apache.org/thread/3mf4cfx070ofsnf9qy0s2v5gqb5sc2g1'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/04/15/1'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-54550'
  - url: 'https://github.com/apache/airflow'
tags:
  - nvd
  - osv
  - pip
epss: 0.00579
epssPercentile: 0.4745
aliases:
  - GHSA-q2hg-643c-gw8h
  - BIT-airflow-2025-54550
  - PYSEC-2026-2353
ecosystem: pip
ingestedAt: '2026-07-13T18:58:01.755Z'
---

## Overview

The example example_xcom that was included in airflow documentation implemented unsafe pattern of reading value
from xcom in the way that could be exploited to allow UI user who had access to modify XComs to perform arbitrary
execution of code on the worker. Since the UI users are already highly trusted, this is a Low severity vulnerability.

It does not affect Airflow release - example_dags are not supposed to be enabled in production environment, however
users following the example could replicate the bad pattern. Documentation of Airflow 3.2.0 contains version of
the example with improved resiliance for that case.

Users who followed that pattern are advised to adjust their implementations accordingly.

## Affected

- `airflow < 3.2.0`

## Remediation

Upgrade past the affected range:

- `airflow 3.2.0`

## Package advisory (CVE-2025-54550)

Affected packages:

- `apache-airflow < 3.2.0`

Patched in:

- `apache-airflow 3.2.0`

Source: https://osv.dev/vulnerability/GHSA-q2hg-643c-gw8h
