CVE-2025-58438Critical▾ Midnightinternetarchive Vulnerable to Directory Traversal in File.download()
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 52.3 · likelihood 0.3 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Oct 27.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via OSV
Last analysed / modified upstream
1.6%
What kind of vulnerability is it?
This is a Critical severity directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library.
Who is impacted?
All users of the internetarchive library versions < 5.5.1 are impacted. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected.
Description of the vulnerability:
The vulnerability existed because the file.download() method did not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory.
Potential Impact: An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used.
Has the problem been patched? Yes, the problem has been patched.
What versions should users upgrade to? Users must upgrade to version 5.5.1 or later.
Is there a way for users to fix or remediate the vulnerability without upgrading? There is no direct workaround that does not involve upgrading the library. The vulnerability is in the core logic of the file download process.
The only alternative for users who absolutely cannot upgrade is to implement their own custom download function that:
However, this essentially re-implements the fix and is not recommended. Upgrading to the patched version is the only safe and supported solution.
internetarchive < 5.5.1Upgrade to a patched release:
internetarchive 5.5.1Connected by shared product, vendor, weakness, or advisory.
CVE-2024-1728High· 8.1Gradio allows users to access arbitrary files
CVE-2024-11042Critical· 9.1InvokeAI Arbitrary File Deletion vulnerability
CVE-2022-31573Critical· 9.3ChainerRL Visualizer 0.1.1 vulnerable to Path Traversal via unsafe use of send_file function
CVE-2024-10902Critical· 9.1DB-GPT vulnerable to Arbitrary File Upload with Path Traversal
CVE-2024-10833Critical· 9.1DB-GPT Absolute Path Traversal in knowledge/{space_name}/document/upload
CVE-2024-8537Critical· 9.1AgentScope path traversal vulnerability