---
id: CVE-2025-59376
title: >-
  feiskyer mcp-kubernetes-server through 0.1.11 does not consider chained
  commands in the implementation of --disable-write and --disable-delete, e.g.,
  it allows a "kubectl version; kubectl delete pod" command because the first
  word (i.e.,…
summary: >-
  feiskyer mcp-kubernetes-server through 0.1.11 does not consider chained
  commands in the implementation of --disable-write and --disable-delete, e.g.,
  it allows a "kubectl version; kubectl delete pod" command because the first
  word (i.e.,…
severity: low
cvss: 3.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-77
  - CWE-863
vendor: feisky
product: mcp-kubernetes-server
affected:
  - mcp-kubernetes-server <= 0.1.11
published: '2025-09-15'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T23:10:00.237'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-59376'
references:
  - url: >-
      https://github.com/feiskyer/mcp-kubernetes-server/blob/78957b6c1a3982080cf6fcaac6f6e9014116a71c/src/mcp_kubernetes_server/main.py#L106-L137
    label: cve@mitre.org
  - url: 'https://github.com/william31212/CVE-Requests-1896609'
    label: cve@mitre.org
  - url: 'https://github.com/william31212/CVE-Requests-1896609'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-59376'
  - url: 'https://github.com/feiskyer/mcp-kubernetes-server'
tags:
  - nvd
  - exploit-available
  - osv
  - pip
epss: 0.00302
epssPercentile: 0.2276
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/william31212/CVE-Requests-1896609'
  checkedAt: '2026-10-27T16:47:52.295Z'
exploitAvailable: true
aliases:
  - GHSA-hjm5-xgj8-vwj6
  - PYSEC-2026-1619
ecosystem: pip
scores:
  nvd: 3.7
  osv: 5.3
ingestedAt: '2026-07-08T18:25:50.259Z'
---

## Overview

feiskyer mcp-kubernetes-server through 0.1.11 does not consider chained commands in the implementation of --disable-write and --disable-delete, e.g., it allows a "kubectl version; kubectl delete pod" command because the first word (i.e., "version") is not a write or delete operation.

## Affected

- `mcp-kubernetes-server <= 0.1.11`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-59376)

Affected packages:

- `mcp-kubernetes-server <= 0.1.11`

Source: https://osv.dev/vulnerability/GHSA-hjm5-xgj8-vwj6
