---
id: CVE-2025-61587
title: Weblate is a web based localization tool
summary: >-
  Weblate is a web based localization tool. An open redirect exists in versions
  5.13.2 and below via the redir parameter on .within.website when Weblate is
  configured with Anubis and REDIRECT_DOMAINS is not set. An attacker can craft
  a URL…
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-601
vendor: weblate
product: weblate
affected:
  - weblate < 5.13.3
patched:
  - weblate 5.13.3
published: '2025-10-01'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T15:10:00.207'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-61587'
references:
  - url: >-
      https://github.com/WeblateOrg/docker/commit/76518342f65b8af8c2b7f7c5d37f84813c1253a1
    label: security-advisories@github.com
  - url: >-
      https://github.com/WeblateOrg/weblate/commit/6b3d73a310279b5630bca8cbd9ea0be28bc67b63
    label: security-advisories@github.com
  - url: >-
      https://github.com/WeblateOrg/weblate/commit/ec3b900f8a52c5c992d9e7014f09397e159ac381
    label: security-advisories@github.com
  - url: >-
      https://github.com/WeblateOrg/weblate/security/advisories/GHSA-3xhv-r4gx-xw99
    label: security-advisories@github.com
  - url: >-
      https://github.com/WeblateOrg/weblate/security/advisories/GHSA-3xhv-r4gx-xw99
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
tags:
  - nvd
  - osv
  - pip
epss: 0.00391
epssPercentile: 0.33048
aliases:
  - PYSEC-2025-269
  - GHSA-3xhv-r4gx-xw99
ecosystem: pip
ingestedAt: '2026-07-13T18:58:06.980Z'
---

## Overview

Weblate is a web based localization tool. An open redirect exists in versions 5.13.2 and below via the redir parameter on .within.website when Weblate is configured with Anubis and REDIRECT_DOMAINS is not set. An attacker can craft a URL on the legitimate domain that redirects a victim to an attacker-controlled site. The redirect can also be used to initiate drive-by downloads (redirecting to a URL that serves a malicious file), increasing the risk to end users. This issue is fixed in version 5.13.3.

## Affected

- `weblate < 5.13.3`

## Remediation

Upgrade past the affected range:

- `weblate 5.13.3`

## Package advisory (CVE-2025-61587)

Affected packages:

- `weblate < 5.13.3`

Patched in:

- `weblate 5.13.3`

Source: https://osv.dev/vulnerability/PYSEC-2025-269
