---
id: CVE-2025-61669
title: Jupyter Server is the backend for Jupyter web applications
summary: >-
  Jupyter Server is the backend for Jupyter web applications. In jupyter_server
  versions through 2.17.0, the next query parameter in the login flow is
  insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows
  redirects …
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-601
vendor: jupyter
product: jupyter_server
affected:
  - jupyter_server < 2.18.0
patched:
  - jupyter_server 2.18.0
published: '2026-05-05'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T09:10:00.160'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-61669'
references:
  - url: >-
      https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-qh7q-6qm3-653w
    label: security-advisories@github.com
  - url: >-
      https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-qh7q-6qm3-653w
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-61669'
  - url: 'https://github.com/jupyter-server/jupyter_server'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-server/PYSEC-2026-67.yaml
tags:
  - nvd
  - osv
  - pip
epss: 0.00244
epssPercentile: 0.15497
aliases:
  - GHSA-qh7q-6qm3-653w
  - PYSEC-2026-67
ecosystem: pip
ingestedAt: '2026-09-12T03:13:01.721Z'
---

## Overview

Jupyter Server is the backend for Jupyter web applications. In jupyter_server versions through 2.17.0, the next query parameter in the login flow is insufficiently validated in `LoginFormHandler._redirect_safe()`, which allows redirects to arbitrary external domains via values such as `///example.com`. An attacker can use a crafted login URL to redirect users to a malicious site and facilitate phishing attacks. This issue is fixed in version 2.18.0.

## Affected

- `jupyter_server < 2.18.0`

## Remediation

Upgrade past the affected range:

- `jupyter_server 2.18.0`

## Package advisory (CVE-2025-61669)

Affected packages:

- `jupyter-server < 2.18.0`

Patched in:

- `jupyter-server 2.18.0`

Source: https://osv.dev/vulnerability/GHSA-qh7q-6qm3-653w
