---
id: CVE-2025-61677
title: >-
  DataChain is a Python-based AI-data warehouse for transforming and analyzing
  unstructured data
summary: >-
  DataChain is a Python-based AI-data warehouse for transforming and analyzing
  unstructured data. Versions 0.34.1 and below allow for deseriaization of
  untrusted data because of the way the DataChain library reads serialized
  objects from e…
severity: low
cvss: 2.5
cvssVector: 'CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N'
cwe:
  - CWE-502
vendor: datachain
product: datachain
affected:
  - datachain < 0.34.2
patched:
  - datachain 0.34.2
published: '2025-10-03'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T22:10:00.563'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-61677'
references:
  - url: >-
      https://github.com/iterative/datachain/commit/914b95610620d50c8d9bee506ccbfa7d4d57fdc0
    label: security-advisories@github.com
  - url: 'https://github.com/iterative/datachain/pull/1358'
    label: security-advisories@github.com
  - url: >-
      https://github.com/iterative/datachain/security/advisories/GHSA-6px8-mr29-cj4r
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-61677'
  - url: 'https://github.com/iterative/datachain'
tags:
  - nvd
  - osv
  - pip
epss: 0.00166
epssPercentile: 0.05789
aliases:
  - GHSA-6px8-mr29-cj4r
  - PYSEC-2026-1288
ecosystem: pip
ingestedAt: '2026-07-08T18:25:46.509Z'
---

## Overview

DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-61677)

Affected packages:

- `datachain < 0.34.2`

Patched in:

- `datachain 0.34.2`

Source: https://osv.dev/vulnerability/GHSA-6px8-mr29-cj4r
