---
id: CVE-2025-63389
title: >-
  A critical authentication bypass vulnerability exists in Ollama platform's API
  endpoints in versions prior to and including v0.12.3
summary: >-
  A critical authentication bypass vulnerability exists in Ollama platform's API
  endpoints in versions prior to and including v0.12.3. The platform exposes
  multiple API endpoints without requiring authentication, enabling remote
  attackers …
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-306
vendor: ollama
product: ollama
affected:
  - ollama <= 0.12.3
published: '2025-12-18'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T11:10:00.203'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-63389'
references:
  - url: 'https://gist.github.com/Cristliu/48dae561696374744d9fced07a544ecd'
    label: cve@mitre.org
  - url: 'https://gist.github.com/Cristliu/b6f4d070fb27932f581be1aadc0923e7'
    label: cve@mitre.org
  - url: 'https://github.com/ollama/ollama/issues'
    label: cve@mitre.org
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-63389'
  - url: 'https://github.com/ollama/ollama'
tags:
  - nvd
  - osv
  - go
epss: 0.00708
epssPercentile: 0.53251
aliases:
  - GHSA-f6mr-38g8-39rg
  - GO-2025-4251
ecosystem: go
ingestedAt: '2026-08-07T19:14:16.622Z'
---

## Overview

A critical authentication bypass vulnerability exists in Ollama platform's API endpoints in versions prior to and including v0.12.3. The platform exposes multiple API endpoints without requiring authentication, enabling remote attackers to perform unauthorized model management operations.

## Affected

- `ollama <= 0.12.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-63389)

Affected packages:

- `github.com/ollama/ollama <= 0.13.5`

Source: https://osv.dev/vulnerability/GHSA-f6mr-38g8-39rg
