---
id: CVE-2025-63721
title: >-
  HummerRisk thru v1.5.0 is using a vulnerable Snakeyaml component, allowing
  attackers with normal user privileges to hit the /rule/add API and thereby
  achieve RCE and take over the server.
summary: >-
  HummerRisk thru v1.5.0 is using a vulnerable Snakeyaml component, allowing
  attackers with normal user privileges to hit the /rule/add API and thereby
  achieve RCE and take over the server.
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: hummerrisk
product: hummerrisk
affected:
  - hummerrisk <= 1.5.0
published: '2025-12-08'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T20:10:00.197'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-63721'
references:
  - url: 'https://gist.github.com/k1ng0fic3/e8c8c9353fff8fa95e2c2952587e9266'
    label: cve@mitre.org
  - url: 'https://github.com/k1ng0fic3/secrisk/blob/main/README.md'
    label: cve@mitre.org
  - url: 'https://gist.github.com/k1ng0fic3/e8c8c9353fff8fa95e2c2952587e9266'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://github.com/k1ng0fic3/secrisk/blob/main/README.md'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
tags:
  - nvd
epss: 0.00492
epssPercentile: 0.4207
ingestedAt: '2026-10-27T18:12:09.306Z'
---

## Overview

HummerRisk thru v1.5.0 is using a vulnerable Snakeyaml component, allowing attackers with normal user privileges to hit the /rule/add API and thereby achieve RCE and take over the server.

## Affected

- `hummerrisk <= 1.5.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
