---
id: CVE-2025-64152
title: >-
  Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
  vulnerability in Apache IoTDB.


  This issue affects Apache IoTDB: from 1.0.0 before 1.3.6, from 2.0.0 before
  2.0.7.


  Users are recommended to upgrade to versio…
summary: >-
  Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
  vulnerability in Apache IoTDB.


  This issue affects Apache IoTDB: from 1.0.0 before 1.3.6, from 2.0.0 before
  2.0.7.


  Users are recommended to upgrade to versio…
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-22
published: '2026-06-26'
updated: '2026-09-29'
sourceUpdated: '2026-09-29T19:10:00.160'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-64152'
references:
  - url: 'https://lists.apache.org/thread/sjms84rlt4g78fwmjcowxmtjp1q8b9q4'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/03/09/3'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-64152'
  - url: 'https://github.com/apache/iotdb/pull/16596'
  - url: >-
      https://github.com/apache/iotdb/commit/3fdfe2e6ca99e3b65b3455c5aeb45cdb2302efab
  - url: >-
      https://github.com/apache/iotdb/commit/7770bacf3d8a04bd4d4dea4d82694c137f48746e
  - url: 'https://github.com/apache/iotdb/releases/tag/v1.3.6'
  - url: 'https://github.com/apache/iotdb/releases/tag/v2.0.7'
  - url: 'https://github.com/advisories/GHSA-h548-jhj8-q85h'
tags:
  - nvd
  - ghsa
  - maven
epss: 0.00537
epssPercentile: 0.45037
ingestedAt: '2026-09-29T19:44:04.088Z'
aliases:
  - GHSA-h548-jhj8-q85h
ecosystem: maven
vendor: apache
product: 'org.apache.iotdb:iotdb-server'
affected:
  - 'org.apache.iotdb:iotdb-server >= 1.0.0, < 1.3.6'
  - 'org.apache.iotdb:iotdb-server >= 2.0.0, < 2.0.7'
patched:
  - 'org.apache.iotdb:iotdb-server 1.3.6'
  - 'org.apache.iotdb:iotdb-server 2.0.7'
---

## Overview

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.

This issue affects Apache IoTDB: from 1.0.0 before 1.3.6, from 2.0.0 before 2.0.7.

Users are recommended to upgrade to version 1.3.6 and 2.0.7, which fixes the issue.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-64152)

Affected packages:

- `org.apache.iotdb:iotdb-server >= 1.0.0, < 1.3.6`
- `org.apache.iotdb:iotdb-server >= 2.0.0, < 2.0.7`

Patched in:

- `org.apache.iotdb:iotdb-server 1.3.6`
- `org.apache.iotdb:iotdb-server 2.0.7`

Source: https://github.com/advisories/GHSA-h548-jhj8-q85h
