---
id: CVE-2025-6544
title: >-
  A deserialization vulnerability exists in h2oai/h2o-3 versions <= 3.46.0.8,
  allowing attackers to read arbitrary system files and execute arbitrary code
summary: >-
  A deserialization vulnerability exists in h2oai/h2o-3 versions <= 3.46.0.8,
  allowing attackers to read arbitrary system files and execute arbitrary code.
  The vulnerability arises from improper handling of JDBC connection parameters,
  whic…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: h2o
product: h2o
affected:
  - 'h2o >= 3.0.0.2, <= 3.46.0.8'
published: '2025-09-21'
updated: '2026-10-05'
sourceUpdated: '2026-10-05T14:10:00.267'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-6544'
references:
  - url: >-
      https://github.com/h2oai/h2o-3/commit/0298ee348f5c73673b7b542158081e79605f5f25
    label: security@huntr.dev
  - url: 'https://huntr.com/bounties/53f35a0f-d644-4f82-93aa-89fe7e0aed40'
    label: security@huntr.dev
  - url: 'https://huntr.com/bounties/53f35a0f-d644-4f82-93aa-89fe7e0aed40'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-6544'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/h2o/PYSEC-2026-349.yaml
  - url: 'https://pypi.org/project/h2o'
  - url: 'https://github.com/advisories/GHSA-5w3j-gwgh-4rfv'
  - url: 'https://github.com/h2oai/h2o-3'
tags:
  - nvd
  - ghsa
  - maven
  - osv
epss: 0.00919
epssPercentile: 0.60061
ingestedAt: '2026-10-01T18:55:42.287Z'
aliases:
  - GHSA-5w3j-gwgh-4rfv
  - PYSEC-2026-349
ecosystem: maven
---

## Overview

A deserialization vulnerability exists in h2oai/h2o-3 versions <= 3.46.0.8, allowing attackers to read arbitrary system files and execute arbitrary code. The vulnerability arises from improper handling of JDBC connection parameters, which can be exploited by bypassing regular expression checks and using double URL encoding. This issue impacts all users of the affected versions.

## Affected

- `h2o >= 3.0.0.2, <= 3.46.0.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-6544)

Affected packages:

- `ai.h2o:h2o-core <= 3.46.0.7`
- `h2o <= 3.46.0.7`

Source: https://github.com/advisories/GHSA-5w3j-gwgh-4rfv
