---
id: CVE-2025-65720
title: >-
  An issue in Open Source GPT Researcher v3.3.7 allows attackers to execute
  arbitrary commands on a victim system via user interaction with a crafted HTML
  page.
summary: >-
  An issue in Open Source GPT Researcher v3.3.7 allows attackers to execute
  arbitrary commands on a victim system via user interaction with a crafted HTML
  page.
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-77
vendor: gpt-researcher
product: gpt-researcher
affected:
  - 'gpt-researcher >= 0.14.5, <= 0.14.7'
published: '2026-07-15'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T22:10:00.247'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-65720'
references:
  - url: 'https://github.com/assafelovic/gpt-researcher'
    label: cve@mitre.org
  - url: 'https://www.ox.security/blog/gpt-researcher-remote-code-execution'
    label: cve@mitre.org
  - url: >-
      https://www.ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem/
    label: cve@mitre.org
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-65720'
  - url: >-
      https://www.ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem
  - url: 'https://github.com/advisories/GHSA-8j86-h8gg-797p'
  - url: 'https://pypi.org/project/gpt-researcher'
tags:
  - nvd
  - osv
  - pip
  - ghsa
epss: 0.00722
epssPercentile: 0.53776
aliases:
  - GHSA-8j86-h8gg-797p
  - PYSEC-2026-4219
ecosystem: pip
ingestedAt: '2026-10-02T23:34:57.404Z'
---

## Overview

An issue in Open Source GPT Researcher v3.3.7 allows attackers to execute arbitrary commands on a victim system via user interaction with a crafted HTML page.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-65720)

Affected packages:

- `gpt-researcher >= 0.14.5, <= 0.14.7`

Source: https://osv.dev/vulnerability/GHSA-8j86-h8gg-797p
