---
id: CVE-2025-66236
title: >-
  Before Airflow 3.2.0, it was unclear that secure Airflow deployments require
  the Deployment Manager to take appropriate actions and pay attention to
  security details and security model of Airflow
summary: >-
  Before Airflow 3.2.0, it was unclear that secure Airflow deployments require
  the Deployment Manager to take appropriate actions and pay attention to
  security details and security model of Airflow. Some assumptions the
  Deployment Manager …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-532
vendor: apache
product: airflow
affected:
  - 'airflow >= 3.0.0, < 3.2.0'
patched:
  - airflow 3.2.0
published: '2026-04-13'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T09:10:00.160'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-66236'
references:
  - url: 'https://github.com/apache/airflow/pull/58662'
    label: security@apache.org
  - url: 'https://lists.apache.org/thread/g8fyy1tkmxkkfk7tx2v6h8mvwzpyykbo'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/04/13/6'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-66236'
  - url: 'https://airflow.apache.org/blog/airflow-3.2.0'
  - url: 'https://github.com/apache/airflow'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2026-8.yaml
tags:
  - nvd
  - cve.org
  - osv
  - pip
epss: 0.00439
epssPercentile: 0.3793
aliases:
  - GHSA-j86x-fwp2-qh7v
  - BIT-airflow-2025-66236
  - PYSEC-2026-8
ecosystem: pip
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-04-15T19:20:26.164642Z'
ingestedAt: '2026-09-12T03:13:01.704Z'
---

## Overview

Before Airflow 3.2.0, it was unclear that secure Airflow deployments require the Deployment Manager to take appropriate actions and pay attention to security details and security model of Airflow. Some assumptions the Deployment Manager could make were not clear or explicit enough, even though Airflow's intentions and security model of Airflow did not suggest different assumptions. The overall security model [1], workload isolation [2], and JWT authentication details [3] are now described in more detail. Users concerned with role isolation and following the Airflow security model of Airflow are advised to upgrade to Airflow 3.2, where several security improvements have been implemented. They should also read and follow the relevant documents to make sure that their deployment is secure enough. It also clarifies that the Deployment Manager is ultimately responsible for securing your Airflow deployment. This had also been communicated via Airflow 3.2.0 Blog announcement [4].

[1] Security Model:  https://airflow.apache.org/docs/apache-airflow/stable/security/jwt_token_authentication.html 
[2] Workload isolation:  https://airflow.apache.org/docs/apache-airflow/stable/security/workload.html 
[3] JWT Token authentication:  https://airflow.apache.org/docs/apache-airflow/stable/security/jwt_token_authentication.html 
[4] Airflow 3.2.0 Blog announcement:  https://airflow.apache.org/blog/airflow-3.2.0/ 



Users are recommended to upgrade to version 3.2.0, which fixes this issue.

## Affected

- `airflow >= 3.0.0, < 3.2.0`

## Remediation

Upgrade past the affected range:

- `airflow 3.2.0`

## Package advisory (CVE-2025-66236)

Affected packages:

- `apache-airflow >= 3.0.0, < 3.2.0`

Patched in:

- `apache-airflow 3.2.0`

Source: https://osv.dev/vulnerability/GHSA-j86x-fwp2-qh7v
