---
id: CVE-2025-66336
title: >-
  Apache Doris MCP Server contains a SQL injection vulnerability in a metadata
  query path
summary: >-
  Apache Doris MCP Server contains a SQL injection vulnerability in a metadata
  query path. A user-controlled database name is directly interpolated into a
  SQL query, and the query is executed without passing the caller's
  authorization cont…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-89
vendor: apache
product: doris_mcp_server
affected:
  - 'doris_mcp_server >= 0.1.0, < 0.6.1'
patched:
  - doris_mcp_server 0.6.1
published: '2026-06-22'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T22:10:00.247'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-66336'
references:
  - url: 'https://lists.apache.org/thread/4l4v3m7ofwrgp4s4s98pjb5l03fcrzo2'
    label: security@apache.org
  - url: 'http://www.openwall.com/lists/oss-security/2026/06/22/1'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-66336'
  - url: 'https://github.com/apache/doris-mcp-server/pull/68'
  - url: 'https://github.com/apache/doris-mcp-server'
  - url: 'https://github.com/advisories/GHSA-pqrj-4gwg-h5f7'
  - url: 'https://pypi.org/project/doris-mcp-server'
tags:
  - nvd
  - osv
  - pip
  - ghsa
epss: 0.00561
epssPercentile: 0.46505
aliases:
  - GHSA-pqrj-4gwg-h5f7
  - PYSEC-2026-4048
ecosystem: pip
ingestedAt: '2026-09-12T00:03:49.069Z'
---

## Overview

Apache Doris MCP Server contains a SQL injection vulnerability in a metadata query path. A user-controlled database name is directly interpolated into a SQL query, and the query is executed without passing the caller's authorization context. This may allow an authenticated attacker, or an anonymous attacker if authentication is disabled, to bypass SQL security validation and access metadata outside the intended database scope.

Affected users are recommended to upgrade to Doris version 0.6.1 or later, which fixes the issue.

## Affected

- `doris_mcp_server >= 0.1.0, < 0.6.1`

## Remediation

Upgrade past the affected range:

- `doris_mcp_server 0.6.1`

## Package advisory (CVE-2025-66336)

Affected packages:

- `doris-mcp-server < 0.6.1`

Patched in:

- `doris-mcp-server 0.6.1`

Source: https://osv.dev/vulnerability/GHSA-pqrj-4gwg-h5f7
