---
id: CVE-2025-67729
title: 'LMDeploy is a toolkit for compressing, deploying, and serving LLMs'
summary: >-
  LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to
  version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy
  where torch.load() is called without the weights_only=True parameter when
  loading m…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: internlm
product: lmdeploy
affected:
  - lmdeploy < 0.11.1
patched:
  - lmdeploy 0.11.1
published: '2025-12-26'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T13:10:00.713'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-67729'
references:
  - url: >-
      https://github.com/InternLM/lmdeploy/commit/eb04b4281c5784a5cff5ea639c8f96b33b3ae5ee
    label: security-advisories@github.com
  - url: >-
      https://github.com/InternLM/lmdeploy/security/advisories/GHSA-9pf3-7rrr-x5jh
    label: security-advisories@github.com
  - url: >-
      https://github.com/InternLM/lmdeploy/security/advisories/GHSA-9pf3-7rrr-x5jh
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-67729'
  - url: 'https://github.com/InternLM/lmdeploy'
tags:
  - nvd
  - osv
  - pip
epss: 0.00508
epssPercentile: 0.43199
aliases:
  - GHSA-9pf3-7rrr-x5jh
  - PYSEC-2026-1578
ecosystem: pip
ingestedAt: '2026-07-08T18:25:48.059Z'
---

## Overview

LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.

## Affected

- `lmdeploy < 0.11.1`

## Remediation

Upgrade past the affected range:

- `lmdeploy 0.11.1`

## Package advisory (CVE-2025-67729)

Affected packages:

- `lmdeploy < 0.11.1`

Patched in:

- `lmdeploy 0.11.1`

Source: https://osv.dev/vulnerability/GHSA-9pf3-7rrr-x5jh
