---
id: CVE-2025-68145
title: >-
  In mcp-server-git versions prior to 2025.12.17, when the server is started
  with the --repository flag to restrict operations to a specific repository
  path, it did not validate that repo_path arguments in subsequent tool calls
  were actual…
summary: >-
  In mcp-server-git versions prior to 2025.12.17, when the server is started
  with the --repository flag to restrict operations to a specific repository
  path, it did not validate that repo_path arguments in subsequent tool calls
  were actual…
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N'
cwe:
  - CWE-22
vendor: lfprojects
product: model_context_protocol_servers
affected:
  - model_context_protocol_servers < 2025.12.18
patched:
  - model_context_protocol_servers 2025.12.18
published: '2025-12-17'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T23:10:00.237'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-68145'
references:
  - url: >-
      https://github.com/modelcontextprotocol/servers/security/advisories/GHSA-j22h-9j4x-23w5
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-68145'
  - url: 'https://github.com/modelcontextprotocol/servers'
tags:
  - nvd
  - osv
  - pip
epss: 0.07032
epssPercentile: 0.94151
aliases:
  - GHSA-j22h-9j4x-23w5
  - PYSEC-2026-1623
ecosystem: pip
ingestedAt: '2026-07-08T18:25:50.523Z'
---

## Overview

In mcp-server-git versions prior to 2025.12.17, when the server is started with the --repository flag to restrict operations to a specific repository path, it did not validate that repo_path arguments in subsequent tool calls were actually within that configured path. This could allow tool calls to operate on other repositories accessible to the server process. The fix adds path validation that resolves both the configured repository and the requested path (following symlinks) and verifies the requested path is within the allowed repository before executing any git operations. Users are advised to upgrade to 2025.12.17 upon release to remediate this issue.

## Affected

- `model_context_protocol_servers < 2025.12.18`

## Remediation

Upgrade past the affected range:

- `model_context_protocol_servers 2025.12.18`

## Package advisory (CVE-2025-68145)

Affected packages:

- `mcp-server-git < 2025.12.18`

Patched in:

- `mcp-server-git 2025.12.18`

Source: https://osv.dev/vulnerability/GHSA-j22h-9j4x-23w5
