---
id: CVE-2025-68151
title: CoreDNS is a DNS server that chains plugins
summary: >-
  CoreDNS is a DNS server that chains plugins. Prior to version 1.14.0, multiple
  CoreDNS server implementations (gRPC, HTTPS, and HTTP/3) lack critical
  resource-limiting controls. An unauthenticated remote attacker can exhaust
  memory and d…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-770
vendor: coredns.io
product: coredns
affected:
  - coredns < 1.14.0
patched:
  - coredns 1.14.0
published: '2026-01-08'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T16:10:00.250'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-68151'
references:
  - url: >-
      https://github.com/coredns/coredns/commit/0d8cbb1a6bcb6bc9c1a489865278b8725fa20812
    label: security-advisories@github.com
  - url: 'https://github.com/coredns/coredns/pull/7490'
    label: security-advisories@github.com
  - url: 'https://github.com/coredns/coredns/security/advisories/GHSA-527x-5wrf-22m2'
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-68151'
  - url: 'https://github.com/coredns/coredns'
tags:
  - nvd
  - osv
  - go
epss: 0.00494
epssPercentile: 0.42201
aliases:
  - GHSA-527x-5wrf-22m2
  - GO-2026-4289
ecosystem: go
ingestedAt: '2026-09-12T03:13:01.754Z'
---

## Overview

CoreDNS is a DNS server that chains plugins. Prior to version 1.14.0, multiple CoreDNS server implementations (gRPC, HTTPS, and HTTP/3) lack critical resource-limiting controls. An unauthenticated remote attacker can exhaust memory and degrade or crash the server by opening many concurrent connections, streams, or sending oversized request bodies. The issue is similar in nature to CVE-2025-47950 (QUIC DoS) but affects additional server types that do not enforce connection limits, stream limits, or message size constraints. Version 1.14.0 contains a patch.

## Affected

- `coredns < 1.14.0`

## Remediation

Upgrade past the affected range:

- `coredns 1.14.0`

## Package advisory (CVE-2025-68151)

Affected packages:

- `github.com/coredns/coredns < 1.14.0`

Patched in:

- `github.com/coredns/coredns 1.14.0`

Source: https://osv.dev/vulnerability/GHSA-527x-5wrf-22m2
