---
id: CVE-2025-71336
title: >-
  Flowise before 3.0.6 (affected versions 2.2.7-patch.1 and earlier) contains an
  unsandboxed remote code execution vulnerability in the Custom MCP feature,
  which is designed to execute OS commands such as launching local MCP servers
summary: >-
  Flowise before 3.0.6 (affected versions 2.2.7-patch.1 and earlier) contains an
  unsandboxed remote code execution vulnerability in the Custom MCP feature,
  which is designed to execute OS commands such as launching local MCP servers.
  Becau…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-78
  - CWE-862
vendor: flowiseai
product: flowise
affected:
  - flowise < 3.0.6
patched:
  - flowise 3.0.6
published: '2026-06-25'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T21:10:00.227'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71336'
references:
  - url: >-
      https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6933-jpx5-q87q
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/flowise-unsandboxed-remote-code-execution-via-custom-mcp
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6933-jpx5-q87q
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://github.com/FlowiseAI/Flowise/pull/5201'
  - url: >-
      https://github.com/FlowiseAI/Flowise/commit/ac7cf30e019cde54905bf09b5d3fe1c6ba42f9b9
  - url: 'https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.6'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71336'
  - url: 'https://github.com/advisories/GHSA-6933-jpx5-q87q'
tags:
  - nvd
  - ghsa
  - npm
epss: 0.01148
epssPercentile: 0.66646
ingestedAt: '2026-09-30T17:13:20.777Z'
aliases:
  - GHSA-6933-jpx5-q87q
ecosystem: npm
---

## Overview

Flowise before 3.0.6 (affected versions 2.2.7-patch.1 and earlier) contains an unsandboxed remote code execution vulnerability in the Custom MCP feature, which is designed to execute OS commands such as launching local MCP servers. Because Flowise's authentication and authorization model is minimal and lacks role-based access control, and the default installation runs without authentication unless FLOWISE_USERNAME and FLOWISE_PASSWORD are set, an attacker can send a crafted JSON payload with the header 'x-request-from: internal' to the /api/v1/node-load-method/customMCP endpoint to execute arbitrary OS commands, resulting in complete compromise of the platform container or server.

## Affected

- `flowise < 3.0.6`

## Remediation

Upgrade past the affected range:

- `flowise 3.0.6`

## Package advisory (CVE-2025-71336)

Affected packages:

- `flowise >= 2.2.7-patch.1, < 3.0.6`

Patched in:

- `flowise 3.0.6`

Source: https://github.com/advisories/GHSA-6933-jpx5-q87q
