---
id: CVE-2025-71344
title: >-
  picklescan before 0.0.30 (affected versions 0.0.26 and earlier) fails to
  detect the ensurepip._run_pip built-in function when scanning pickle files,
  allowing attackers to execute arbitrary code
summary: >-
  picklescan before 0.0.30 (affected versions 0.0.26 and earlier) fails to
  detect the ensurepip._run_pip built-in function when scanning pickle files,
  allowing attackers to execute arbitrary code. Malicious pickle files embedding
  ensurepip…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-502
vendor: picklescan
product: picklescan
affected:
  - picklescan < 0.0.30
patched:
  - picklescan 0.0.30
published: '2026-06-22'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T22:10:00.247'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71344'
references:
  - url: >-
      https://github.com/mmaitre314/picklescan/security/advisories/GHSA-xp4f-hrf8-rxw7
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/picklescan-arbitrary-code-execution-via-undetected-ensurepip-run-pip-function
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/mmaitre314/picklescan/security/advisories/GHSA-xp4f-hrf8-rxw7
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://github.com/mmaitre314/picklescan/commit/1931c2d04eaca8d20597705ff39cab78ba364e4b
  - url: 'https://github.com/mmaitre314/picklescan'
tags:
  - nvd
  - osv
  - pip
epss: 0.00467
epssPercentile: 0.40264
aliases:
  - GHSA-xp4f-hrf8-rxw7
  - PYSEC-2026-1792
ecosystem: pip
ingestedAt: '2026-07-08T18:25:54.210Z'
---

## Overview

picklescan before 0.0.30 (affected versions 0.0.26 and earlier) fails to detect the ensurepip._run_pip built-in function when scanning pickle files, allowing attackers to execute arbitrary code. Malicious pickle files embedding ensurepip._run_pip calls in __reduce__ methods bypass picklescan detection and achieve remote code execution upon pickle.load() invocation.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-71344)

Affected packages:

- `picklescan < 0.0.30`

Patched in:

- `picklescan 0.0.30`

Source: https://osv.dev/vulnerability/GHSA-xp4f-hrf8-rxw7
