---
id: CVE-2025-71357
title: >-
  picklescan before 0.0.30 fails to detect malicious pickle files using
  idlelib.pyshell.ModifiedInterpreter.runcommand in reduce methods
summary: >-
  picklescan before 0.0.30 fails to detect malicious pickle files using
  idlelib.pyshell.ModifiedInterpreter.runcommand in reduce methods. Attackers
  can embed undetected code in pickle files that executes remote commands when
  loaded by vict…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-502
vendor: mmaitre314
product: picklescan
affected:
  - picklescan < 0.0.30
patched:
  - picklescan 0.0.30
published: '2026-06-21'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T22:10:00.247'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71357'
references:
  - url: >-
      https://github.com/mmaitre314/picklescan/security/advisories/GHSA-j343-8v2j-ff7w
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/picklescan-arbitrary-code-execution-via-undetected-idlelib-pyshell-modifiedinterpreter-runcommand
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/mmaitre314/picklescan/security/advisories/GHSA-j343-8v2j-ff7w
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://github.com/mmaitre314/picklescan/commit/1931c2d04eaca8d20597705ff39cab78ba364e4b
  - url: 'https://github.com/mmaitre314/picklescan'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/picklescan/PYSEC-2026-246.yaml
  - url: 'https://github.com/advisories/GHSA-j343-8v2j-ff7w'
tags:
  - nvd
  - osv
  - pip
  - ghsa
epss: 0.00392
epssPercentile: 0.33186
aliases:
  - GHSA-j343-8v2j-ff7w
  - PYSEC-2026-246
ecosystem: pip
ingestedAt: '2026-09-11T19:57:09.310Z'
---

## Overview

picklescan before 0.0.30 fails to detect malicious pickle files using idlelib.pyshell.ModifiedInterpreter.runcommand in reduce methods. Attackers can embed undetected code in pickle files that executes remote commands when loaded by victims.

## Affected

- `picklescan < 0.0.30`

## Remediation

Upgrade past the affected range:

- `picklescan 0.0.30`

## Package advisory (CVE-2025-71357)

Affected packages:

- `picklescan < 0.0.30`

Patched in:

- `picklescan 0.0.30`

Source: https://osv.dev/vulnerability/GHSA-j343-8v2j-ff7w
