---
id: CVE-2025-71368
title: >-
  picklescan before 0.0.30 fails to detect the doctest.debug_script function
  when analyzing pickle files, allowing attackers to execute arbitrary code
summary: >-
  picklescan before 0.0.30 fails to detect the doctest.debug_script function
  when analyzing pickle files, allowing attackers to execute arbitrary code.
  Remote attackers can craft malicious pickle files embedding
  doctest.debug_script calls …
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-502
vendor: picklescan
product: picklescan
affected:
  - picklescan < 0.0.30
patched:
  - picklescan 0.0.30
published: '2026-06-30'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T21:10:00.227'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71368'
references:
  - url: >-
      https://github.com/mmaitre314/picklescan/security/advisories/GHSA-fqq6-7vqf-w3fg
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/picklescan-arbitrary-code-execution-via-undetected-doctest-debug-script
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/mmaitre314/picklescan/security/advisories/GHSA-fqq6-7vqf-w3fg
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: >-
      https://github.com/mmaitre314/picklescan/commit/1931c2d04eaca8d20597705ff39cab78ba364e4b
  - url: 'https://github.com/mmaitre314/picklescan'
tags:
  - nvd
  - osv
  - pip
epss: 0.00839
epssPercentile: 0.57619
aliases:
  - GHSA-fqq6-7vqf-w3fg
ecosystem: pip
ingestedAt: '2026-07-08T18:25:49.101Z'
---

## Overview

picklescan before 0.0.30 fails to detect the doctest.debug_script function when analyzing pickle files, allowing attackers to execute arbitrary code. Remote attackers can craft malicious pickle files embedding doctest.debug_script calls that bypass picklescan detection and execute arbitrary commands upon pickle.load invocation.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-71368)

Affected packages:

- `picklescan < 0.0.30`

Patched in:

- `picklescan 0.0.30`

Source: https://osv.dev/vulnerability/GHSA-fqq6-7vqf-w3fg
