---
id: CVE-2025-71379
title: >-
  vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial
  of service (ReDoS) vulnerabilities
summary: >-
  vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial
  of service (ReDoS) vulnerabilities. Several regex patterns — in
  vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible
  serving chat endpoint —…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-1333
vendor: vllm
product: vllm
affected:
  - 'vllm >= 0.6.3, < 0.9.0'
patched:
  - vllm 0.9.0
published: '2026-06-20'
updated: '2026-10-12'
sourceUpdated: '2026-10-12T22:10:00.247'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71379'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-j828-28rj-hfhp
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/vllm-regular-expression-denial-of-service-in-multiple-components
    label: disclosure@vulncheck.com
  - url: 'https://github.com/vllm-project/vllm/pull/18454'
  - url: >-
      https://github.com/vllm-project/vllm/commit/4fc1bf813ad80172c1db31264beaef7d93fe0601
  - url: 'https://github.com/vllm-project/vllm'
tags:
  - nvd
  - osv
  - pip
epss: 0.00481
epssPercentile: 0.41257
aliases:
  - GHSA-j828-28rj-hfhp
ecosystem: pip
ingestedAt: '2026-07-08T18:25:50.612Z'
---

## Overview

vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.

## Affected

- `vllm >= 0.6.3, < 0.9.0`

## Remediation

Upgrade past the affected range:

- `vllm 0.9.0`

## Package advisory (CVE-2025-71379)

Affected packages:

- `vllm >= 0.6.3, < 0.9.0`

Patched in:

- `vllm 0.9.0`

Source: https://osv.dev/vulnerability/GHSA-j828-28rj-hfhp
