---
id: CVE-2025-71431
title: >-
  Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection
  vulnerability because certain endpoints do not sanitize user-supplied
  parameters before using them in LDAP queries
summary: >-
  Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection
  vulnerability because certain endpoints do not sanitize user-supplied
  parameters before using them in LDAP queries. Attackers can supply crafted
  LDAP filter syntax …
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'
cwe:
  - CWE-90
vendor: frappe
product: frappe
affected:
  - frappe < 14.99.2
  - frappe >= 15.0.0 < 15.86.0
published: '2026-10-12'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T15:17:18.437'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-71431'
references:
  - url: 'https://github.com/frappe/frappe/security/advisories/GHSA-qrq5-v93p-8xhw'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-before-15.86.0-ldap-injection-via-unsanitized-endpoint-parameters
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.0025
epssPercentile: 0.16206
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-15T14:05:22.038886Z'
ingestedAt: '2026-10-13T00:09:02.609Z'
---

## Overview

Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection vulnerability because certain endpoints do not sanitize user-supplied parameters before using them in LDAP queries. Attackers can supply crafted LDAP filter syntax through these parameters to alter the resulting directory queries.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
