---
id: CVE-2025-7647
title: >-
  The llama-index-core package, up to version 0.12.44, contains a vulnerability
  in the `get_cache_dir()` function where a predictable, hardcoded directory
  path `/tmp/llama_index` is used on Linux systems without proper security
  controls
summary: >-
  The llama-index-core package, up to version 0.12.44, contains a vulnerability
  in the `get_cache_dir()` function where a predictable, hardcoded directory
  path `/tmp/llama_index` is used on Linux systems without proper security
  controls. T…
severity: high
cvss: 7.3
cvssVector: 'CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L'
cwe:
  - CWE-378
vendor: llama-index-core
product: llama-index-core
affected:
  - llama-index-core < 0.13.0
patched:
  - llama-index-core 0.13.0
published: '2025-09-27'
updated: '2026-10-09'
sourceUpdated: '2026-10-09T10:10:00.193'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-7647'
references:
  - url: >-
      https://github.com/run-llama/llama_index/commit/98816394d57c7f53f847ed7b60725e69d0e7aae4
    label: security@huntr.dev
  - url: 'https://huntr.com/bounties/a2baa08f-98bf-47a8-ac83-06f7411afd9e'
    label: security@huntr.dev
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-7647'
  - url: 'https://github.com/run-llama/llama_index'
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-7647.json
  - url: 'https://access.redhat.com/security/cve/CVE-2025-7647'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2399917'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2025-7647'
  - url: 'https://access.redhat.com/errata/RHSA-2025:18984'
tags:
  - nvd
  - osv
  - pip
  - csaf
  - vex
  - red-hat
epss: 0.0015
epssPercentile: 0.04137
aliases:
  - GHSA-cr7q-2w66-hjcm
  - PYSEC-2026-1562
ecosystem: pip
ingestedAt: '2026-07-08T18:25:48.552Z'
scores:
  nvd: 7.3
  vendor: 8.4
---

## Overview

The llama-index-core package, up to version 0.12.44, contains a vulnerability in the `get_cache_dir()` function where a predictable, hardcoded directory path `/tmp/llama_index` is used on Linux systems without proper security controls. This vulnerability allows attackers on multi-user systems to steal proprietary models, poison cached embeddings, or conduct symlink attacks. The issue affects all Linux deployments where multiple users share the same system. The vulnerability is classified under CWE-379, CWE-377, and CWE-367, indicating insecure temporary file creation and potential race conditions.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-7647)

Affected packages:

- `llama-index-core < 0.13.0`

Patched in:

- `llama-index-core 0.13.0`

Source: https://osv.dev/vulnerability/GHSA-cr7q-2w66-hjcm

## Vendor advisories

- **RHSA-2025:18984** · Red Hat · fixed in: Red Hat Ansible Automation Platform 2.5 for RHEL 8 · released 2025-10-22 · [advisory](https://access.redhat.com/errata/RHSA-2025:18984)
- **Red Hat VEX** · Important · affected: OpenShift Lightspeed · no fix planned: OpenShift Lightspeed · updated 2026-10-15 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-7647.json)
