---
id: CVE-2025-7707
title: >-
  The llama_index library version 0.12.33 sets the NLTK data directory to a
  subdirectory of the codebase by default, which is world-writable in multi-user
  environments
summary: >-
  The llama_index library version 0.12.33 sets the NLTK data directory to a
  subdirectory of the codebase by default, which is world-writable in multi-user
  environments. This configuration allows local users to overwrite, delete, or
  corrupt…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-377
vendor: llamaindex
product: llamaindex
affected:
  - 'llamaindex >= 0.12.33, < 0.13.0'
patched:
  - llamaindex 0.13.0
published: '2025-10-13'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T12:10:00.217'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-7707'
references:
  - url: >-
      https://github.com/run-llama/llama_index/commit/98816394d57c7f53f847ed7b60725e69d0e7aae4
    label: security@huntr.dev
  - url: 'https://huntr.com/bounties/3fe2c8ab-6727-4aef-a0ef-4d2818e48803'
    label: security@huntr.dev
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-7707'
  - url: 'https://github.com/run-llama/llama_index'
tags:
  - nvd
  - osv
  - pip
epss: 0.00186
epssPercentile: 0.08132
aliases:
  - GHSA-rg9h-vx28-xxp5
  - PYSEC-2026-1556
ecosystem: pip
scores:
  nvd: 7.8
  osv: 7.1
ingestedAt: '2026-07-08T18:25:52.714Z'
---

## Overview

The llama_index library version 0.12.33 sets the NLTK data directory to a subdirectory of the codebase by default, which is world-writable in multi-user environments. This configuration allows local users to overwrite, delete, or corrupt NLTK data files, leading to potential denial of service, data tampering, or privilege escalation. The vulnerability arises from the use of a shared cache directory instead of a user-specific one, making it susceptible to local data tampering and denial of service.

## Affected

- `llamaindex >= 0.12.33, < 0.13.0`

## Remediation

Upgrade past the affected range:

- `llamaindex 0.13.0`

## Package advisory (CVE-2025-7707)

Affected packages:

- `llama-index < 0.13.0`

Patched in:

- `llama-index 0.13.0`

Source: https://osv.dev/vulnerability/GHSA-rg9h-vx28-xxp5
