---
id: CVE-2026-100106
title: >-
  The FiboSearch – Ajax Search for WooCommerce plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'purchased_plan' parameter
  in all versions up to, and including, 1.34.2 due to insufficient input
  sanitization and out…
summary: >-
  The FiboSearch – Ajax Search for WooCommerce plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the 'purchased_plan' parameter
  in all versions up to, and including, 1.34.2 due to insufficient input
  sanitization and out…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: damian-gora
product: FiboSearch – Ajax Search for WooCommerce
affected:
  - fibosearch_ajax_search_for_woocommerce <= 1.34.2
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:16:57.717'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100106'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/assets/js/admin.js#L555
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/assets/js/tooltip.min.js#L4
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/vendor/freemius/wordpress-sdk/includes/class-freemius.php#L4548
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/vendor/freemius/wordpress-sdk/includes/fs-core-functions.php#L223
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/vendor/freemius/wordpress-sdk/includes/fs-html-escaping-functions.php#L123
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/vendor/freemius/wordpress-sdk/includes/managers/class-fs-admin-notice-manager.php#L421
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/ajax-search-for-woocommerce/tags/1.34.2/vendor/freemius/wordpress-sdk/templates/admin-notice.php#L110
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3734423%40ajax-search-for-woocommerce%2Ftags%2F1.34.3&old=3684506%40ajax-search-for-woocommerce%2Ftags%2F1.34.2
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/7db3475a-3a70-4776-8ea3-337192f88973?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00228
epssPercentile: 0.13482
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:15:36.078721Z'
ingestedAt: '2026-10-16T08:02:23.118Z'
---

## Overview

The FiboSearch – Ajax Search for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'purchased_plan' parameter in all versions up to, and including, 1.34.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that the site owner has previously completed the standard Freemius opt-in flow; once that condition is met, any Subscriber can reach the vulnerable handler simply by loading /wp-admin/profile.php with the requisite query parameters.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
