---
id: CVE-2026-100125
title: >-
  CAI Content Credentials is affected by an Improper Input Validation
  vulnerability that could result in a Security feature bypass
summary: >-
  CAI Content Credentials is affected by an Improper Input Validation
  vulnerability that could result in a Security feature bypass. An attacker
  could leverage this vulnerability to bypass security measures and gain
  unauthorized write acces…
severity: medium
cvss: 5.9
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N'
cwe:
  - CWE-20
vendor: adobe
product: c2pa
affected:
  - c2pa < 0.91.1
  - c2pa-web < 0.15.3
  - c2patool < 0.28.1
patched:
  - c2pa 0.91.1
  - c2pa-web 0.15.3
  - c2patool 0.28.1
published: '2026-10-13'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T18:30:18.380'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100125'
references:
  - url: >-
      https://www.adobe.com/trust/security/products/content-credentials-sdk/apsb26-163.html
    label: psirt@adobe.com
tags:
  - nvd
  - cve.org
epss: 0.00574
epssPercentile: 0.47228
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-14T18:45:08.694498Z'
ingestedAt: '2026-10-13T23:03:54.729Z'
---

## Overview

CAI Content Credentials is affected by an Improper Input Validation vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized write access. Exploit depends on conditions beyond the attacker's control. Exploitation of this issue does not require user interaction.

## Affected

- `c2pa < 0.91.1`
- `c2pa-web < 0.15.3`
- `c2patool < 0.28.1`

## Remediation

Upgrade past the affected range:

- `c2pa 0.91.1`
- `c2pa-web 0.15.3`
- `c2patool 0.28.1`
