---
id: CVE-2026-100140
title: >-
  Integer overflow vulnerability in XML parsing functionality of Qt5Compat
  impacts Qt
summary: >-
  An integer overflow vulnerability in the Qt XML parsing (Qt5Compat /
  QXmlSimpleReader) functionality of Qt.
severity: low
cvss: 1.9
cvssVector: >-
  CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/R:U/U:Green
cvssSource: cna
cwe:
  - CWE-190
vendor: qt
product: qt
affected:
  - qt >= 6.0.0 <= 6.8.9
  - qt >= 6.9.0 <= 6.11.2
  - qt 6.12.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-02T16:54:43.471958Z'
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T16:55:00.571Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-100140'
references:
  - url: >-
      https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-100140:
  - url: 'https://codereview.qt-project.org/c/qt/qt5compat/+/768900'
  - url: 'https://codereview.qt-project.org/c/qt/qt5compat/+/764751'
  - url: 'https://codereview.qt-project.org/c/qt/qt5compat/+/768901'
  - url: 'https://codereview.qt-project.org/c/qt/qt5compat/+/768902'
tags:
  - cve.org
epss: 0.00167
epssPercentile: 0.05988
ingestedAt: '2026-11-05T19:30:42.714Z'
---

## Overview

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

## Affected

- `qt >= 6.0.0 <= 6.8.9`
- `qt >= 6.9.0 <= 6.11.2`
- `qt 6.12.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
