---
id: CVE-2026-100147
title: >-
  The FunnelKit – Funnel Builder for WooCommerce Checkout plugin for WordPress
  is vulnerable to Stored Cross-Site Scripting via the 'shipping_first_name'
  parameter in all versions up to, and including, 3.16.0.5 due to insufficient
  input sa…
summary: >-
  The FunnelKit – Funnel Builder for WooCommerce Checkout plugin for WordPress
  is vulnerable to Stored Cross-Site Scripting via the 'shipping_first_name'
  parameter in all versions up to, and including, 3.16.0.5 due to insufficient
  input sa…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
published: '2026-10-10'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T13:29:12.567'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100147'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/funnel-builder/tags/3.16.0.5/modules/thankyou-pages/includes/class-wffn-ecomm-tracking.php#L1114
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/funnel-builder/tags/3.16.0.5/modules/thankyou-pages/includes/class-wffn-ecomm-tracking.php#L211
    label: security@wordfence.com
  - url: 'https://plugins.trac.wordpress.org/changeset/3733861/'
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3733886/funnel-builder/trunk/modules/thankyou-pages/includes/class-wffn-ecomm-tracking.php
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/1807b544-e5fd-403b-85a6-e20bd4f10dec?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00297
epssPercentile: 0.22247
ingestedAt: '2026-10-10T08:27:37.782Z'
vendor: teamfunnelkit
product: FunnelKit – Funnel Builder for WooCommerce Checkout
affected:
  - funnelkit_funnel_builder_for_woocommerce_checkout <= 3.16.0.5
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-11T12:12:10.253950Z'
---

## Overview

The FunnelKit – Funnel Builder for WooCommerce Checkout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'shipping_first_name' parameter in all versions up to, and including, 3.16.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
