---
id: CVE-2026-100648
title: >-
  vllm before 0.29.0 fails to enforce VLLM_MAX_AUDIO_CLIP_FILESIZE_MB limit in
  multimodal chat audio decoding, allowing unauthenticated clients to bypass
  file size restrictions
summary: >-
  vllm before 0.29.0 fails to enforce VLLM_MAX_AUDIO_CLIP_FILESIZE_MB limit in
  multimodal chat audio decoding, allowing unauthenticated clients to bypass
  file size restrictions. Attackers can submit oversized audio files through
  chat endpo…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-400
  - CWE-770
vendor: vllm
product: vllm
affected:
  - vllm < 0.29.0
patched:
  - vllm 0.29.0
published: '2026-09-26'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T19:40:20.020'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100648'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-jcq2-4gch-5qhf
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/vllm-before-0.29.0-uncontrolled-resource-consumption-via-audio-decoding
    label: disclosure@vulncheck.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-100648.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-100648'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2541825'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-100648'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100648'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00351
epssPercentile: 0.28607
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-09-28T16:40:22.871965Z'
ingestedAt: '2026-09-26T13:33:20.921Z'
---

## Overview

vllm before 0.29.0 fails to enforce VLLM_MAX_AUDIO_CLIP_FILESIZE_MB limit in multimodal chat audio decoding, allowing unauthenticated clients to bypass file size restrictions. Attackers can submit oversized audio files through chat endpoints to consume excessive memory and CPU resources during decoding.

## Affected

- `vllm < 0.29.0`

## Remediation

Upgrade past the affected range:

- `vllm 0.29.0`

## Vendor advisories

- **Red Hat VEX** · Moderate · affected: Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) · no fix planned: Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) · updated 2026-10-01 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-100648.json)
