---
id: CVE-2026-100649
title: >-
  vLLM before 0.29.0 contains a resource-limit bypass vulnerability in
  PyNvVideoCodec decoder allocation where sampler subclass shadowing allows
  independent counter increments
summary: >-
  vLLM before 0.29.0 contains a resource-limit bypass vulnerability in
  PyNvVideoCodec decoder allocation where sampler subclass shadowing allows
  independent counter increments. Unauthenticated attackers can select different
  sampler subclas…
severity: low
cvss: 3.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L'
cwe:
  - CWE-770
vendor: vllm
product: vllm
affected:
  - vllm < 0.29.0
patched:
  - vllm 0.29.0
published: '2026-09-26'
updated: '2026-10-06'
sourceUpdated: '2026-10-06T19:37:35.050'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100649'
references:
  - url: >-
      https://github.com/vllm-project/vllm/security/advisories/GHSA-j682-9xp5-rrf3
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/vllm-before-0.29.0-resource-limit-bypass-via-sampler-subclass
    label: disclosure@vulncheck.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-100649.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-100649'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2541914'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-100649'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100649'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00341
epssPercentile: 0.27436
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-02T18:00:00.754862Z'
ingestedAt: '2026-09-26T13:33:20.920Z'
---

## Overview

vLLM before 0.29.0 contains a resource-limit bypass vulnerability in PyNvVideoCodec decoder allocation where sampler subclass shadowing allows independent counter increments. Unauthenticated attackers can select different sampler subclasses in video requests to exceed configured decoder limits and exhaust unaccounted GPU memory.

## Affected

- `vllm < 0.29.0`

## Remediation

Upgrade past the affected range:

- `vllm 0.29.0`

## Vendor advisories

- **Red Hat VEX** · Low · affected: Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) · no fix planned: Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI) · updated 2026-10-06 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-100649.json)
