---
id: CVE-2026-100840
title: >-
  MONAI through 1.6.0 contains a remote code execution vulnerability in the
  bundle configuration engine that resolves _target_ values to arbitrary
  importable callables without an allow list and passes $ expressions to Python
  eval()
summary: >-
  MONAI through 1.6.0 contains a remote code execution vulnerability in the
  bundle configuration engine that resolves _target_ values to arbitrary
  importable callables without an allow list and passes $ expressions to Python
  eval(). Attack…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-95
vendor: project-monai
product: monai
affected:
  - monai <= 1.6.0
published: '2026-09-27'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T15:40:44.640'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100840'
references:
  - url: >-
      https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-873f-pvrv-4x83
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/monai-through-1.6.0-remote-code-execution-via-bundle-configuration
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-873f-pvrv-4x83
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
tags:
  - nvd
  - cve.org
  - exploit-available
  - osv
  - pip
epss: 0.00313
epssPercentile: 0.24008
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-28T16:44:24.110450Z'
ingestedAt: '2026-09-27T02:41:45.572Z'
aliases:
  - PYSEC-2026-4015
  - GHSA-873f-pvrv-4x83
ecosystem: pip
patched:
  - monai 1.6.1rc0
---

## Overview

MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().

## Affected

- `monai <= 1.6.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-100840)

Affected packages:

- `monai < 1.6.1rc0`

Patched in:

- `monai 1.6.1rc0`

Source: https://osv.dev/vulnerability/PYSEC-2026-4015
