---
id: CVE-2026-100843
title: >-
  MONAI versions before 1.6.0 contain a remote code execution vulnerability in
  the algo_from_pickle() function due to unsafe pickle.loads() deserialization
  in monai/auto3dseg/utils.py
summary: >-
  MONAI versions before 1.6.0 contain a remote code execution vulnerability in
  the algo_from_pickle() function due to unsafe pickle.loads() deserialization
  in monai/auto3dseg/utils.py. Attackers can craft malicious pickle files that
  execut…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: project-monai
product: monai
affected:
  - monai < 1.6.0
patched:
  - monai 1.6.0
published: '2026-09-27'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T16:17:02.217'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100843'
references:
  - url: >-
      https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-qxq5-qhx6-94qw
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/monai-before-1.6.0-remote-code-execution-via-algo-from-pickle
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-qxq5-qhx6-94qw
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://github.com/Project-MONAI/MONAI'
  - url: 'https://github.com/Project-MONAI/MONAI/releases/tag/1.6.0'
  - url: 'https://github.com/advisories/GHSA-89gg-p5r5-q6r4'
tags:
  - nvd
  - cve.org
  - exploit-available
  - osv
  - pip
epss: 0.00305
epssPercentile: 0.23187
aliases:
  - GHSA-qxq5-qhx6-94qw
  - PYSEC-2026-4018
ecosystem: pip
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-30T15:17:12.845348Z'
ingestedAt: '2026-09-27T02:41:45.573Z'
---

## Overview

MONAI versions before 1.6.0 contain a remote code execution vulnerability in the algo_from_pickle() function due to unsafe pickle.loads() deserialization in monai/auto3dseg/utils.py. Attackers can craft malicious pickle files that execute arbitrary system commands when deserialized by the vulnerable function.

## Affected

- `monai < 1.6.0`

## Remediation

Upgrade past the affected range:

- `monai 1.6.0`

## Package advisory (CVE-2026-100843)

Affected packages:

- `monai < 1.6.0`

Patched in:

- `monai 1.6.0`

Source: https://osv.dev/vulnerability/GHSA-qxq5-qhx6-94qw
