---
id: CVE-2026-100845
title: >-
  MONAI before 1.6.0 contains an unsafe deserialization vulnerability in the
  NumpyReader class that unconditionally uses numpy.load with allow_pickle=True
  when loading .npy and .npz files
summary: >-
  MONAI before 1.6.0 contains an unsafe deserialization vulnerability in the
  NumpyReader class that unconditionally uses numpy.load with allow_pickle=True
  when loading .npy and .npz files. Attackers can craft malicious .npy files
  with pick…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-502
vendor: project-monai
product: monai
affected:
  - monai < 1.6.0
patched:
  - monai 1.6.0
published: '2026-09-27'
updated: '2026-09-30'
sourceUpdated: '2026-09-30T15:25:51.697'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-100845'
references:
  - url: >-
      https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-wg9g-w2j2-8pgr
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/monai-before-1.6.0-remote-code-execution-via-numpyreader
    label: disclosure@vulncheck.com
  - url: >-
      https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-wg9g-w2j2-8pgr
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://github.com/Project-MONAI/MONAI/pull/8875'
  - url: 'https://github.com/Project-MONAI/MONAI'
  - url: 'https://github.com/Project-MONAI/MONAI/releases/tag/1.6.0'
tags:
  - nvd
  - cve.org
  - exploit-available
  - osv
  - pip
epss: 0.00203
epssPercentile: 0.10154
aliases:
  - GHSA-wg9g-w2j2-8pgr
  - PYSEC-2026-4020
ecosystem: pip
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-28T13:56:28.228012Z'
ingestedAt: '2026-09-27T02:41:45.574Z'
---

## Overview

MONAI before 1.6.0 contains an unsafe deserialization vulnerability in the NumpyReader class that unconditionally uses numpy.load with allow_pickle=True when loading .npy and .npz files. Attackers can craft malicious .npy files with pickle payloads that execute arbitrary code when loaded through MONAI's standard data pipeline.

## Affected

- `monai < 1.6.0`

## Remediation

Upgrade past the affected range:

- `monai 1.6.0`

## Package advisory (CVE-2026-100845)

Affected packages:

- `monai < 1.6.0`

Patched in:

- `monai 1.6.0`

Source: https://osv.dev/vulnerability/GHSA-wg9g-w2j2-8pgr
