---
id: CVE-2026-101294
title: >-
  IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.10 and IBM
  WebSphere Application Server 8.5, and 9.0 could allow a remote attacker to
  bypass cryptographic signature verification due to improper verification of
  cryptogr…
summary: >-
  IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.10 and IBM
  WebSphere Application Server 8.5, and 9.0 could allow a remote attacker to
  bypass cryptographic signature verification due to improper verification of
  cryptogr…
severity: high
cvss: 8.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N'
cwe:
  - CWE-325
published: '2026-10-13'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T16:08:15.347'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-101294'
references:
  - url: 'https://www.ibm.com/support/pages/node/7292235'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
ingestedAt: '2026-10-13T21:58:14.163Z'
vendor: IBM
product: WebSphere Application Server - Liberty
affected:
  - websphere_application_server_-_liberty >= 17.0.0.3 <= 26.0.0.10
  - websphere_application_server 8.5
  - websphere_application_server 9.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-14T14:16:10.221055Z'
epss: 0.00213
epssPercentile: 0.11519
---

## Overview

IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.10 and IBM WebSphere Application Server 8.5, and 9.0 could allow a remote attacker to bypass cryptographic signature verification due to improper verification of cryptographic signature.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
