---
id: CVE-2026-101329
title: >-
  IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated
  attacker to obtain sensitive information due to improper access control.
summary: >-
  IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated
  attacker to obtain sensitive information due to improper access control.
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-284
vendor: langflow
product: langflow
affected:
  - 'langflow >= 1.0.0, < 1.12.3'
patched:
  - langflow 1.12.3
published: '2026-10-07'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T18:29:28.400'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-101329'
references:
  - url: 'https://www.ibm.com/support/pages/node/7290694'
    label: psirt@us.ibm.com
tags:
  - nvd
  - cve.org
epss: 0.0026
epssPercentile: 0.17589
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-08T14:53:45.750399Z'
ingestedAt: '2026-10-07T01:27:17.508Z'
---

## Overview

IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to obtain sensitive information due to improper access control.

## Affected

- `langflow >= 1.0.0, < 1.12.3`

## Remediation

Upgrade past the affected range:

- `langflow 1.12.3`
