---
id: CVE-2026-101935
title: >-
  Echo Knowledge Base <= 17.214.0 - Reflected Cross-Site Scripting via
  'new_kb_config' Parameter
summary: >-
  The Echo Knowledge Base – Documentation, FAQs, Chat & Smart Search plugin for
  WordPress is vulnerable to Reflected Cross-Site Scripting via the
  'new_kb_config' parameter (specifically the article-mobile-break-point-v2 key,
  among other co…
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: echoplugins
product: 'Echo Knowledge Base – Documentation, FAQs, Chat & Smart Search'
affected:
  - echo_knowledge_base_documentation_faqs_chat_smart_search <= 17.214.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:28:44.586449Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:41:50.091Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-101935'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/3bfab9cf-4ccb-45fc-83ce-b5250f0f6482?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/echo-knowledge-base/tags/17.214.0/includes/features/articles/class-epkb-articles-setup.php#L319
  - url: >-
      https://plugins.trac.wordpress.org/browser/echo-knowledge-base/tags/17.214.0/includes/features/articles/class-epkb-articles-setup.php#L131
  - url: >-
      https://plugins.trac.wordpress.org/browser/echo-knowledge-base/tags/17.214.0/includes/admin/editor/class-epkb-frontend-editor.php#L848
  - url: >-
      https://plugins.trac.wordpress.org/browser/echo-knowledge-base/tags/17.214.0/includes/admin/editor/class-epkb-frontend-editor.php#L1072
  - url: >-
      https://plugins.trac.wordpress.org/browser/echo-knowledge-base/tags/17.214.0/includes/class-epkb-utilities.php#L836
  - url: >-
      https://plugins.trac.wordpress.org/browser/echo-knowledge-base/tags/17.214.0/includes/features/layouts/class-epkb-layouts-setup.php#L45
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3727663/echo-knowledge-base/trunk/includes/admin/editor/class-epkb-frontend-editor.php
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3727647%40echo-knowledge-base%2Ftags%2F17.311.0&old=3672811%40echo-knowledge-base%2Ftags%2F17.214.0
tags:
  - cve.org
epss: 0.00254
epssPercentile: 0.17007
ingestedAt: '2026-10-28T08:07:15.089Z'
---

## Overview

The Echo Knowledge Base – Documentation, FAQs, Chat & Smart Search plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'new_kb_config' parameter (specifically the article-mobile-break-point-v2 key, among other config keys interpolated into the <style> element) in versions up to, and including, 17.214.0 This is due to insufficient input sanitization and output escaping in EPKB_Frontend_Editor::fe_preview_config() and EPKB_Articles_Setup: on every knowledge base article page view, when the request supplies epkb_fe_reload_mode=on, an attacker-controlled JSON blob is merged over the stored KB configuration and several values are concatenated directly into a stylesheet emitted inside a literal <style> element without escaping (minify_css() does not strip <, > or /). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user (with Editor-level access or above, holding the manage_categories capability, or an Administrator) into performing an action such as clicking on a specially crafted link.

## Affected

- `echo_knowledge_base_documentation_faqs_chat_smart_search <= 17.214.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
