---
id: CVE-2026-102407
title: >-
  Incorrect Authorization (CWE-863) in Elasticsearch can lead to unauthorized
  data stream modification via Accessing Functionality Not Properly Constrained
  by ACLs (CAPEC-1)
summary: >-
  Incorrect Authorization (CWE-863) in Elasticsearch can lead to unauthorized
  data stream modification via Accessing Functionality Not Properly Constrained
  by ACLs (CAPEC-1). An authenticated user with sufficient privileges over a
  single r…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L'
cwe:
  - CWE-863
vendor: elastic
product: elasticsearch
affected:
  - 'elasticsearch >= 7.17.5, <= 7.17.29'
  - 'elasticsearch >= 8.2.2, < 8.19.19'
  - 'elasticsearch >= 9.0.0, < 9.3.8'
  - 'elasticsearch >= 9.4.0, < 9.4.4'
patched:
  - elasticsearch 9.4.4
published: '2026-10-06'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T18:48:49.860'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102407'
references:
  - url: >-
      https://discuss.elastic.co/t/elasticsearch-8-19-19-9-3-8-9-4-4-security-update-esa-2026-188/390861
    label: security@elastic.co
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102407.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-102407'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-102407'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00219
epssPercentile: 0.12282
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-06T19:56:21.979941Z'
ingestedAt: '2026-10-06T20:16:42.471Z'
---

## Overview

Incorrect Authorization (CWE-863) in Elasticsearch can lead to unauthorized data stream modification via Accessing Functionality Not Properly Constrained by ACLs (CAPEC-1). An authenticated user with sufficient privileges over a single resource could use the Modify Data Streams API to modify a data stream to which they were not otherwise authorized, potentially injecting data into it or affecting its ability to be searched normally. This issue does not allow an attacker to read the contents of a data stream they do not otherwise have access to.

## Affected

- `elasticsearch >= 7.17.5, <= 7.17.29`
- `elasticsearch >= 8.2.2, < 8.19.19`
- `elasticsearch >= 9.0.0, < 9.3.8`
- `elasticsearch >= 9.4.0, < 9.4.4`

## Remediation

Upgrade past the affected range:

- `elasticsearch 9.4.4`

## Vendor advisories

- **Red Hat VEX** · updated 2026-10-06 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102407.json)
