---
id: CVE-2026-102435
title: >-
  Ultra Addons for Contact Form 7 <= 3.5.54 - Unauthenticated PHP Object
  Injection to Arbitrary File Deletion via CF7 Form Field
summary: >-
  The Ultra Addons for Contact Form 7 plugin for WordPress is vulnerable to
  arbitrary file deletion due to insufficient file path validation in the
  _getObjAttr function in all versions up to, and including, 3.5.54. This makes
  it possible f…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-502
vendor: themefic
product: Ultra Addons for Contact Form 7
affected:
  - ultra_addons_for_contact_form_7 <= 3.5.54
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-11-03T17:55:13.004891Z'
published: '2026-11-02'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T18:33:51.051Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-102435'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/187777a4-3438-489c-ad3b-7e16753189d6?source=cve
  - url: >-
      https://plugins.svn.wordpress.org/ultimate-addons-for-contact-form-7/tags/3.5.52/addons/pdf-generator/pdf-generator.php
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3738548/ultimate-addons-for-contact-form-7
tags:
  - cve.org
epss: 0.0059
epssPercentile: 0.48478
ingestedAt: '2026-11-05T20:33:06.369Z'
---

## Overview

The Ultra Addons for Contact Form 7 plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the _getObjAttr function in all versions up to, and including, 3.5.54. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). This requires the PDF Generator add-on to be active and a Contact Form 7 form to be configured for PDF generation, as the WPCF7_Submission POP gadget chain relies on CF7 being present to complete the file deletion via __destruct(). Note: This vulnerability can only be exploited when the PDF generator feature is enabled.

## Affected

- `ultra_addons_for_contact_form_7 <= 3.5.54`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
