---
id: CVE-2026-102555
title: A flaw was found in libsoup
summary: >-
  A flaw was found in libsoup. The soup_uri_decode_data_uri() function
  incorrectly treated base64 data-URI payloads as NUL-terminated strings when
  calling g_base64_decode_inplace(). If the percent-decoded payload contained
  embedded NUL byt…
severity: high
cvss: 8.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H'
cwe:
  - CWE-125
vendor: gnome
product: libsoup
affected:
  - libsoup < 3.7.3
  - enterprise_linux = 9.0
  - enterprise_linux = 10.0
patched:
  - libsoup 3.7.3
published: '2026-09-29'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T17:17:09.120'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102555'
references:
  - url: 'https://access.redhat.com/errata/RHSA-2026:83618'
    label: secalert@redhat.com
  - url: 'https://access.redhat.com/security/cve/CVE-2026-102555'
    label: secalert@redhat.com
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2543224'
    label: secalert@redhat.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102555.json
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-102555'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102555'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-09-29T18:16:58.196973Z'
epss: 0.00369
epssPercentile: 0.30596
ingestedAt: '2026-09-29T17:41:02.261Z'
---

## Overview

A flaw was found in libsoup. The soup_uri_decode_data_uri() function incorrectly treated base64 data-URI payloads as NUL-terminated strings when calling g_base64_decode_inplace(). If the percent-decoded payload contained embedded NUL bytes, the decoded length could remain uninitialized and be used as the size of the returned GBytes. This can lead to an out-of-bounds read or application crash when processing a crafted data URI.

## Affected

- `libsoup < 3.7.3`
- `enterprise_linux = 9.0`
- `enterprise_linux = 10.0`

## Remediation

Upgrade past the affected range:

- `libsoup 3.7.3`

## Vendor advisories

- **Red Hat VEX** · Important · affected: Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 9 · no fix planned: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 9 · updated 2026-10-02 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102555.json)
