---
id: CVE-2026-102562
title: >-
  The AcyMailing plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the customField[] parameter of the public frontusers::subscribe
  endpoint in versions up to, and including, 11.1.0
summary: >-
  The AcyMailing plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the customField[] parameter of the public frontusers::subscribe
  endpoint in versions up to, and including, 11.1.0. This is due to insufficient
  input san…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: acyba
product: >-
  AcyMailing – An Ultimate Newsletter Plugin and Marketing Automation Solution
  for WordPress
affected:
  - >-
    acymailing_an_ultimate_newsletter_plugin_and_marketing_automation_solution_for_wordpress
    <= 11.1.0
published: '2026-10-13'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T17:17:10.010'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102562'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/acymailing/tags/11.1.0/back/Classes/FieldClass.php#L292
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/acymailing/tags/11.1.0/back/Classes/UserClass.php#L1187
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/acymailing/tags/11.1.0/back/Core/wordpress/security.php#L122
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/acymailing/tags/11.1.0/back/dynamics/subscriber/SubscriberInsertion.php#L159
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/acymailing/tags/11.1.0/front/FrontControllers/FrontusersController.php#L69
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/acymailing/tags/11.1.0/front/FrontViews/Archive/tmpl/view.php#L17
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3729031%40acymailing&new=3729031%40acymailing
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/eb8f03fb-d1af-4727-87d7-58dbe4013d8a?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-15T10:48:57.922394Z'
epss: 0.00247
epssPercentile: 0.16084
ingestedAt: '2026-10-13T08:19:03.890Z'
---

## Overview

The AcyMailing plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the customField[] parameter of the public frontusers::subscribe endpoint in versions up to, and including, 11.1.0. This is due to insufficient input sanitization and output escaping in the acym_cleanVar() sanitizer, whose HTML-tag stripper only matches complete tags (requiring a closing '>'), together with SubscriberInsertion::replaceUserInformation() and the archive view template, which substitute the stored subscriber field value into the mail body and emit it without HTML encoding. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses the online-archive URL for the poisoned subscriber, including administrators who click the plugin-generated link in the Subscribers → History screen.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
