---
id: CVE-2026-102578
title: A flaw was found in Moodle
summary: >-
  A flaw was found in Moodle. An authenticated attacker with access to the
  question bank web service can submit unsanitized input directly into database
  queries, resulting in a SQL (Structured Query Language) injection
  vulnerability. This …
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N'
cwe:
  - CWE-89
vendor: moodle
product: moodle
affected:
  - moodle < 4.5.13
  - 'moodle >= 5.0.0, < 5.0.9'
  - 'moodle >= 5.1.0, < 5.1.6'
  - 'moodle >= 5.2.0, < 5.2.2'
patched:
  - moodle 5.2.2
published: '2026-09-30'
updated: '2026-10-01'
sourceUpdated: '2026-10-01T14:38:42.597'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102578'
references:
  - url: >-
      http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-89383
    label: patrick@puiterwijk.org
  - url: 'https://access.redhat.com/security/cve/CVE-2026-102578'
    label: patrick@puiterwijk.org
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2543632'
    label: patrick@puiterwijk.org
  - url: 'https://moodle.org/mod/forum/discuss.php?d=482496'
    label: patrick@puiterwijk.org
tags:
  - nvd
  - cve.org
  - exploit-available
epss: 0.00299
epssPercentile: 0.22711
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-09-30T14:36:52.250310Z'
ingestedAt: '2026-09-30T09:00:29.910Z'
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/caveeroo/CVE-2026-102578'
  checkedAt: '2026-11-06T16:52:41.637Z'
exploitAvailable: true
---

## Overview

A flaw was found in Moodle. An authenticated attacker with access to the question bank web service can submit unsanitized input directly into database queries, resulting in a SQL (Structured Query Language) injection vulnerability. This issue could allow an attacker to view, alter, or delete sensitive data stored in the underlying database.

## Affected

- `moodle < 4.5.13`
- `moodle >= 5.0.0, < 5.0.9`
- `moodle >= 5.1.0, < 5.1.6`
- `moodle >= 5.2.0, < 5.2.2`

## Remediation

Upgrade past the affected range:

- `moodle 5.2.2`
