---
id: CVE-2026-102692
title: >-
  RIOT is an open-source microcontroller operating system designed for Internet
  of Things devices and other embedded systems
summary: >-
  RIOT is an open-source microcontroller operating system designed for Internet
  of Things devices and other embedded systems. Prior to 2026.07, nanocoap
  accepts oversized CoAP Block2 option values without enforcing the 20-bit
  maximum block…
severity: critical
cvss: 9.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H'
cwe:
  - CWE-190
  - CWE-787
vendor: RIOT-OS
product: RIOT
affected:
  - RIOT < 2026.07
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T22:17:08.800'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102692'
references:
  - url: >-
      https://github.com/RIOT-OS/RIOT/commit/6b283ace3565d931b3edff7e115d4f79339253b8
    label: security-advisories@github.com
  - url: >-
      https://github.com/RIOT-OS/RIOT/commit/ee1fa0ef91874494823d476392572aeefdbc6b74
    label: security-advisories@github.com
  - url: 'https://github.com/RIOT-OS/RIOT/releases/tag/2026.07'
    label: security-advisories@github.com
  - url: 'https://github.com/RIOT-OS/RIOT/security/advisories/GHSA-8365-gj33-rgpf'
    label: security-advisories@github.com
tags:
  - nvd
  - cve.org
epss: 0.0035
epssPercentile: 0.28499
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-16T20:52:34.763359Z'
ingestedAt: '2026-10-16T17:24:46.894Z'
---

## Overview

RIOT is an open-source microcontroller operating system designed for Internet of Things devices and other embedded systems. Prior to 2026.07, nanocoap accepts oversized CoAP Block2 option values without enforcing the 20-bit maximum block number, allowing block offset multiplication to overflow on 32-bit targets. The affected master baseline is commit aeeae69e; the verified fix is later on master and remains unreleased. The oversized value passes from coap_get_blockopt() to coap_block_slicer_init(). A remote CoAP client can send a malformed Block2 option that produces an invalid slice range and can cause out-of-bounds memory access, denial of service, or memory corruption. This vulnerability is fixed in 2026.07.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
