---
id: CVE-2026-102827
title: >-
  simple-git, an interface for running git commands in any node.js application,
  enables applications to execute Git operations from JavaScript
summary: >-
  simple-git, an interface for running git commands in any node.js application,
  enables applications to execute Git operations from JavaScript. Prior to
  4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names
  with liter…
severity: high
cvss: 8.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-77
  - CWE-88
vendor: simple-git_project
product: simple-git
affected:
  - simple-git < 4.0.0
patched:
  - simple-git 4.0.0
published: '2026-09-29'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T20:11:17.640'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102827'
references:
  - url: >-
      https://github.com/steveukx/git-js/commit/98864c678444d9336357c844efa4fd5a7984c0d7
    label: security-advisories@github.com
  - url: 'https://github.com/steveukx/git-js/pull/1193'
    label: security-advisories@github.com
  - url: 'https://github.com/steveukx/git-js/releases/tag/simple-git@4.0.0'
    label: security-advisories@github.com
  - url: 'https://github.com/steveukx/git-js/security/advisories/GHSA-858h-whjf-mvg5'
    label: security-advisories@github.com
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102827'
  - url: 'https://github.com/advisories/GHSA-858h-whjf-mvg5'
tags:
  - nvd
  - cve.org
  - ghsa
  - npm
  - exploit-available
epss: 0.00576
epssPercentile: 0.47333
aliases:
  - GHSA-858h-whjf-mvg5
ecosystem: npm
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-02T12:21:03.495651Z'
ingestedAt: '2026-09-29T19:44:04.149Z'
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/D7EAD/CVE-2026-102827'
  checkedAt: '2026-10-27T16:53:30.962Z'
exploitAvailable: true
---

## Overview

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.

## Affected

- `simple-git < 4.0.0`

## Remediation

Upgrade past the affected range:

- `simple-git 4.0.0`

## Package advisory (CVE-2026-102827)

Affected packages:

- `simple-git <= 3.36.0`

Patched in:

- `simple-git 4.0.0`

Source: https://github.com/advisories/GHSA-858h-whjf-mvg5
