---
id: CVE-2026-102830
title: >-
  JupyterLab is an extensible environment for interactive and reproducible
  computing, based on the Jupyter Notebook Architecture
summary: >-
  JupyterLab is an extensible environment for interactive and reproducible
  computing, based on the Jupyter Notebook Architecture. From JupyterLab 3.0.0
  until 4.5.11 and 4.6.4, and in JupyterLite Core 0.8.3 and earlier, the
  Plural-Forms hea…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-79
  - CWE-94
  - CWE-625
vendor: jupyterlab
product: jupyterlab
affected:
  - 'jupyterlab >= 3.0.0, < 4.5.11'
  - 'jupyterlab >= 4.6.0, < 4.6.4'
  - jupyterlite-core < 0.8.4
published: '2026-09-29'
updated: '2026-09-29'
sourceUpdated: '2026-09-29T21:40:15.583'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102830'
references:
  - url: >-
      https://github.com/jupyterlab/jupyterlab/commit/985a3223cd77fd4f991cd90066342a90711d70f6
    label: security-advisories@github.com
  - url: >-
      https://github.com/jupyterlab/jupyterlab/commit/de324ae91346c713c4f5e5485f97b6e914e0f774
    label: security-advisories@github.com
  - url: >-
      https://github.com/jupyterlab/jupyterlab/commit/f9de43dc565a1118120d466117f877a189a4ce90
    label: security-advisories@github.com
  - url: 'https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11'
    label: security-advisories@github.com
  - url: 'https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4'
    label: security-advisories@github.com
  - url: >-
      https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-3jqq-pw4j-pqcj
    label: security-advisories@github.com
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102830.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-102830'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2543512'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-102830'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-102830'
  - url: 'https://github.com/advisories/GHSA-3jqq-pw4j-pqcj'
  - url: 'https://github.com/jupyterlab/jupyterlab'
  - url: 'https://pypi.org/project/jupyterlab'
  - url: 'https://pypi.org/project/jupyterlite-core'
tags:
  - nvd
  - cve.org
  - csaf
  - vex
  - red-hat
  - ghsa
  - pip
  - osv
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-09-29T20:00:12.172481Z'
ingestedAt: '2026-09-29T19:44:04.150Z'
aliases:
  - GHSA-3jqq-pw4j-pqcj
  - PYSEC-2026-4056
  - PYSEC-2026-4059
ecosystem: pip
patched:
  - jupyterlab 4.6.4
  - jupyterlab 4.5.11
  - jupyterlite-core 0.8.4
epss: 0.00261
epssPercentile: 0.17701
---

## Overview

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 3.0.0 until 4.5.11 and 4.6.4, and in JupyterLite Core 0.8.3 and earlier, the Plural-Forms header in a selected third-party language pack can append JavaScript after a valid plural rule because prefix-only regular-expression validation accepts a matching prefix without requiring the entire header to match. JupyterLab passes the accepted expression to new Function, so loading the catalogue and translating a plural string executes the appended code in the authenticated JupyterLab origin. Where Jupyter Server kernels, terminals, and APIs are exposed, the code can use authenticated server APIs to read or modify files and run code. Impact is much more limited in JupyterLite because it typically lacks most exposed Jupyter Server surfaces. The default English locale is unaffected because it does not load a translation catalogue. This issue is fixed in JupyterLab 4.5.11 and 4.6.4 and JupyterLite Core 0.8.4.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Vendor advisories

- **Red Hat VEX** · Moderate · affected: Migration Toolkit for Applications 8, Red Hat OpenShift AI (RHOAI) · no fix planned: Migration Toolkit for Applications 8, Red Hat OpenShift AI (RHOAI) · updated 2026-09-29 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-102830.json)

## Package advisory (CVE-2026-102830)

Affected packages:

- `jupyterlab >= 4.6.0, <= 4.6.3`
- `jupyterlab >= 3.0.0, <= 4.5.10`
- `jupyterlite-core <= 0.8.3`

Patched in:

- `jupyterlab 4.6.4`
- `jupyterlab 4.5.11`
- `jupyterlite-core 0.8.4`

Source: https://github.com/advisories/GHSA-3jqq-pw4j-pqcj
