---
id: CVE-2026-103039
title: >-
  Gravity Forms <= 3.1.2 - Unauthenticated PHP Object Injection via Post Custom
  Field
summary: >-
  The Gravity Forms plugin for WordPress is vulnerable to PHP Object Injection
  in all versions up to, and including, 3.1.2 via a Post Custom Field whose
  input type is List. This is due to GFFormsModel::create_post() passing the
  submitted v…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-502
vendor: Gravity Forms
product: Gravity Forms
affected:
  - gravity_forms <= 3.1.2
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-30T15:48:33.243446Z'
exploitAvailable: true
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T15:57:19.794Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-103039'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ec1fba15-81e5-42e3-9154-1978c3f81b26?source=cve
  - url: 'https://docs.gravityforms.com/'
tags:
  - cve.org
  - exploit-available
epss: 0.00508
epssPercentile: 0.43537
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/noxcrypt-x/CVE-2026-103039'
  checkedAt: '2026-11-05T16:25:07.444Z'
ingestedAt: '2026-11-05T16:24:31.039Z'
---

## Overview

The Gravity Forms plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.1.2 via a Post Custom Field whose input type is List. This is due to GFFormsModel::create_post() passing the submitted value to WordPress' unrestricted global maybe_unserialize() rather than the plugin's own hardened GFCommon::maybe_unserialize(), which was added in 3.1.1 and passes allowed_classes => false precisely to prevent object instantiation. Where the field has a content template enabled, the submitted row reaches that call verbatim. This makes it possible for unauthenticated attackers to inject a PHP object into post meta. No PHP Object Injection gadget chain is present in the plugin itself; however, if a gadget chain is present via an additional plugin or theme, it could allow the attacker to perform actions such as remote code execution. Where the custom field is mapped to the protected _wp_page_template meta key, WordPress itself supplies the chain: validate_file() accepts non-scalars, WP_Theme::__toString() then resolves an attacker-controlled path, and on hosts with a readable PEAR install and register_argc_argv enabled this yields remote code execution.

## Affected

- `gravity_forms <= 3.1.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
