---
id: CVE-2026-103092
title: Langflow OSS is affected by multiple vulnerabilities
summary: >-
  IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated
  attacker to execute arbitrary SQL commands due to improper access control.
severity: high
cvss: 8.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L'
cvssSource: cna
cwe:
  - CWE-284
vendor: IBM
product: Langflow OSS
affected:
  - langflow_oss >= 1.0.0 <= 1.12.3
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T16:15:46.513797Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T17:17:22.934Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-103092'
references:
  - url: 'https://www.ibm.com/support/pages/node/7293015'
tags:
  - cve.org
epss: 0.00407
epssPercentile: 0.34965
ingestedAt: '2026-11-01T22:02:40.974Z'
---

## Overview

IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary SQL commands due to improper access control.

## Affected

- `langflow_oss >= 1.0.0 <= 1.12.3`

## Remediation

IBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ 



For Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.
