---
id: CVE-2026-103110
title: >-
  Pexip Infinity before 38.2, plus 39.0, 39.1 and 40.0, is affected by improper
  input validation that allows a remote attacker to execute code remotely as an
  unprivileged user on a Pexip Infinity Conferencing Node.
summary: >-
  Pexip Infinity before 38.2, plus 39.0, 39.1 and 40.0, is affected by improper
  input validation that allows a remote attacker to execute code remotely as an
  unprivileged user on a Pexip Infinity Conferencing Node.
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-787
vendor: pexip
product: pexip_infinity
affected:
  - pexip_infinity < 38.2
  - 'pexip_infinity >= 39.0, <= 39.1'
  - pexip_infinity = 40.0
patched:
  - pexip_infinity 38.2
published: '2026-09-30'
updated: '2026-10-05'
sourceUpdated: '2026-10-05T20:20:44.153'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-103110'
references:
  - url: 'https://docs.pexip.com/admin/security_bulletins.htm'
    label: cve@mitre.org
tags:
  - nvd
  - cve.org
epss: 0.00621
epssPercentile: 0.49551
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-02T12:53:09.564046Z'
ingestedAt: '2026-09-30T03:56:19.556Z'
---

## Overview

Pexip Infinity before 38.2, plus 39.0, 39.1 and 40.0, is affected by improper input validation that allows a remote attacker to execute code remotely as an unprivileged user on a Pexip Infinity Conferencing Node.

## Affected

- `pexip_infinity < 38.2`
- `pexip_infinity >= 39.0, <= 39.1`
- `pexip_infinity = 40.0`

## Remediation

Upgrade past the affected range:

- `pexip_infinity 38.2`
